curl fehlermeldung

Alles rund ums PayPal im XT Commerce Shop
Heinzel
Beiträge: 14
Registriert: Mi 31. Mär 2010, 17:15

Re: curl fehlermeldung

Beitrag von Heinzel » Fr 20. Apr 2012, 14:37

Michael hat geschrieben:"Nur" Techniker is gut..:-) - ich bin auch "nur" Programmierer und kein Shop-Betreiber...
:D deshalb ja auch in""""
Michael hat geschrieben: Nein - das Test-Tool und unsere curl -k -D von der Konsole aus haben ja noch gar nichts mit einem PP Konto zu tun.
Das kommt erst später wenn du aus dem Shop heraus mit den API Daten zu PP gehst.
natürlich :oops: Der Dau war ich .. Sorry.

Heinzel
Beiträge: 14
Registriert: Mi 31. Mär 2010, 17:15

Re: curl fehlermeldung

Beitrag von Heinzel » Sa 21. Apr 2012, 12:20

Auf Grund eines Hinweises, dass es an openssl liegen könnte, hab jetzt ein
Downgrade auf openssl_1.0.0e-3 (vorher openssl_1.0.1-4) gemacht und mit:

openssl s_client -connect paypal.com:443 -state -nbio

wird das Zertifikat ausgespuckt, was vorher nicht der Fall war. Das sieht doch gut aus.
Aber das Testtool vom Shop funktioniert noch immer nicht. :-/

EDIT: Wenn ich SO den Pfad mitgebe, krieg ich ein OK

openssl s_client -CApath /etc/ssl/certs/ -connect paypal.com:443

Und die Ausgabe von openssl version -d

zeigt nicht auf /etc/ssl sondern auf
OPENSSLDIR: "/usr/lib/ssl" und das ist falsch.
Hast du ne Idee, wie ich das "gerade biegen" kann?

Heinzel
Beiträge: 14
Registriert: Mi 31. Mär 2010, 17:15

Re: curl fehlermeldung

Beitrag von Heinzel » So 22. Apr 2012, 15:28

Auch den Pfad beim Curl Befehl mitgeben funktioniert

Code: Alles auswählen

curl --capath /etc/ssl/certs/ -k -D - https://www.paypal.com/cgi-bin/webscr?cmd=_notify-validate
HTTP/1.1 200 OK
Date: Sun, 22 Apr 2012 13:25:44 GMT
X-Frame-Options: SAMEORIGIN
Set-Cookie: cwrClyrK4LoCV1fydGbAxiNL6iG=gSLSgsOjRn6eO8Ec66KLZpUuJxxTV0DZKAc_H5ZLE7yUAPsTFJJaUfLwfSUgM9Y0vExAuWG1DvaUXzIJzGt0H3YH_0tq-i0AMZMmEX6jxj1_fi7SpeKAjHRm2TW%7c-y9AebVCyt1n_4cLs_GvoXSyVB09wq9hORJ3M5mOivgLIKMb0ARrKTxjDXfkmaFeaf2b9W%7cVfXff4hdB506QDaCtczmN0Dg9jzwEbke95NZLJH2dGQZJEpkW2VJxgZqVdiRi5cppqaZZ0%7c1335101144; domain=.paypal.com; path=/; Secure; HttpOnly
Set-Cookie: cookie_check=yes; expires=Wed, 20-Apr-2022 13:25:44 GMT; domain=.paypal.com; path=/; Secure; HttpOnly
Set-Cookie: navcmd=_notify-validate; domain=.paypal.com; path=/; Secure; HttpOnly
Set-Cookie: navlns=0.0; expires=Sat, 17-Apr-2032 13:25:44 GMT; domain=.paypal.com; path=/; Secure; HttpOnly
Set-Cookie: Apache=10.73.8.60.1335101144372902; path=/; expires=Tue, 15-Apr-42 13:25:44 GMT
Vary: Accept-Encoding
Strict-Transport-Security: max-age=14400
Content-Type: text/html; charset=UTF-8
Set-Cookie: TS6a0e62=75963f45e8dab916249da17bd910468c798189a09f97efd54f9406d8a0e2458903ecfe03634137d16081497ffaa6df6385ae782bba64fcf83ecccf34b4608ba7ef77a33e; Path=/
Transfer-Encoding: chunked

Michael
Administrator
Beiträge: 422
Registriert: Fr 2. Jan 2009, 12:13

Re: curl fehlermeldung

Beitrag von Michael » So 22. Apr 2012, 16:05

Mojn,

entweder du änderst die Verzeichnissrechte auf das jetztige Verzeichnis /usr.... oder du änderst die
Konfig so, dass es in das /etc... schreibt.
Viele Grüße - Michael

Antworten